Logged in users are unable to access their project viewers

Incident Report for Stitch3D

Resolved

All project viewers are back to normal for all users.
Posted May 26, 2026 - 18:15 EDT

Investigating

Due to third-party auth systems having issues, our systems are unable to render project viewers for signed in users at this time. All public links and existing sessions should not be affected. We are currently investigating.
Posted May 26, 2026 - 17:49 EDT
This incident affected: Project Viewer.