Some point clouds are immediately failing our upload pipeline

Incident Report for Stitch3D

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 16:55 EDT

Update

A fix was identified and pushed to the production environment. We will continue to test and monitor to ensure no further interruptions occur.
Posted Mar 09, 2026 - 16:54 EDT

Investigating

We are currently investigating an issue where some point clouds are not able to process right now.
Posted Mar 09, 2026 - 16:42 EDT
This incident affected: Point Cloud Upload Pipeline.